Actyx-http-connector compatibility

Is the actyx-http-connector compatible with the Pond Version 3?

In my test I get the following error:
…\node_modules@actyx-contrib\actyx-http-connector\lib\index.js:208
pond.getNodeConnectivity({ callback: function (state) { return (nodeConnectivityState = state); } });

TypeError: pond.getNodeConnectivity is not a function

Hi, I’m on it, I try to finish it today :slight_smile:
I keep you in touch

The new version is now available at npmjs.com. :tada:

Update it with npm update @actyx-contrib/actyx-http-connector

2 Likes

Hi, Thanks for the update.
When I download and run the sample project, it runs fine (GitHub - actyx-contrib/actyx-http-connector).
However, when I want to use the function from the npm package I still get the message:
TypeError: pond.getNodeConnectivity is not a function

I use the following versions:
@actyx-contrib/actyx-http-connector": "^1.0.0,
@actyx/pond”: “^3.0.1”

Have you made sure your node_modules isn’t stale?
Does rm -rf node_modules && npm install help?

I have reinstalled my node_modules. But the error still exists.

Hi,

Sorry for this delay. The new build pipeline did not work as expected.

@actyx-contrib/actyx-http-connector - npm is now available with the fixed version.

Now it works great.
Thank you (:

1 Like