Actyx on Android11

Hi, our clients tablets have updated to Android 11 and we cannot downgrade them. Do you have a version of actyx that runs on android versions higher than 10 for us?

At the moment ADB gets spammed with:

E/com.actyx(1068): node::node_api: SwarmEvent::ListenerError Permission denied (os error 13)

Our cordova app cannot connect to http://localhost:4454/api/v2/node/id and we cannot reach the actyx node with ax or the node-manager from the outside.

The actyx interface tells us actyx is running tho :slight_smile:

Thanks for your help!

Hi @CCFrankUrbainsky,

thanks for reporting this :pray:.
Currently, Android 11 is not officially supported as stated in Actyx Reference | Actyx Developer. This is due to us having to provide compatibility back to Android 6.

However, you can find a custom build of the most current version v2.8.1 that supports Android 11 here. It is tested in a variety of settings; we are not aware of any ill side effects. If you run into issues with this build, please let us know.

HTH

1 Like