How to use volumes in actyxOS

I try to deploy an application with two custom volumes (one for log files, one for ini files).
If I run the container outside actyx everything works fine (I can see the log files and the application finds the ini files). But inside actyx nothing happens. Here’s my docker-compose.yml:

version: "3.3"

services:
  focusiotbridge:
    command: dotnet focusIoTBridge.dll -configpath ./inis/
    image: focusiotbridge
    restart: always
    ports:          
     - "4840:4840"
    volumes:
     - logs:/app/logs
     - inis:/app/inis

volumes:
  logs:
    driver_opts:
      o: bind
      type: none
      device: /home/focus/iotbridgedata/logs
  inis:
    driver_opts:
      o: bind
      type: none
      device: /home/focus/iotbridgedata/inis

What am I doing wrong?

Hi,

at the first look, it seems fine.

Did you try to run the container next to the ActyxOS container? Probably you will get some useful logs.

In the new version, ActyxOS is always available from the local device without the DEV_MODE and it is going to be the primary way to run apps.

ahh, this will not work.

When you deploy into ActyxOS, you life in docker in docker, so /home/focus/… do not exist there. Just try to deploy next to ActyxOS.

Next to ActyxOS everything works as expected.
How do I activate DEV_MODE?
After that how can I push data into ActyxOS (simply by changing the IP address into the docker container’s IP address?)

I solved it by myself.
The DEV_MODE can be activated by setting the environment variable AX_DEV_MODE=1
For pushing data into ActyxOS I had to change my container’s network into bridge

2 Likes