I cant start the advanced tutorial on windows

Hi there,
Im new to the Actyx world and im having trouble using Actyx 2.2.0. I wrote my own little mock connector for machines and the dashboard from the advanced example cant find it even though it is started. On startup I get no errors in the dashboard or the connector. When I start the ActyxOS my connector tells me that Im using an old version, as it is the installer for 1.1.5. But if i only use the background service from version 2.2.0 the dashboard UI cant be loaded and the “connecting to Actyx” message is shown. Could someone help me please.

Best Regards

Felix

Hi @FelixVeitl & welcome to the community :wave:! Great to hear you’re giving Actyx a spin.

As to your question, I’m not sure I fully follow.
You downloaded Actyx v2.2.0 from Actyx Releases | Actyx Developer and installed it, right?
You said you are able to start the apps and see no error - if Actyx is not running, the apps should tell you so:
image

Once you start Actyx and the machine connector (from the tutorial project), the apps should render and display the machine.
This is how the dashboard is supposed to look like:

Where does the 1.1.5 version come from? Is that an old ActyxOS release? Since v2, it is called only Actyx, perhaps that’s where the confusion comes from?

Which platform are you on? As you’re talking about the installer, I guess you’re using Windows?

If you tell us the concrete steps that led to the issue, I guess I can help you better.

Hi Werner, currently Im working on windows and did following steps:

  1. Firstly I dowloaded Actyx, the cli and the node manager from the releases page and installed it.
  2. I downloaded the advanced tutorial from the Actyx download page and set up the project in vs code.
  3. I wrote my own little machine-connector as a mock to simulate a whole process

The connector worked fine before v2 but since I upgraded to v2 the dashboard doesnt show the connector in the available machines sector, but I can start the connector without any errors.

When I upgraded to v2 I did the steps mentioned in the release page. These are:

  1. Replace the actyxos-sdk with the actyx-sdk dependency
  2. Upgrade the actyx/pond version to 3.0
  3. Delete the old event log to ensure compatibility

About the 1.1.5 version, yes that is the ActyxOS version. I thought too that the Actyx app in Program Files/Actyx is the new OS, but when I start this app, I only get following error message and the background service gets stopped.
image

EDIT: The log folder is C:\Program Files\Actyx\Node, had it wrong in the previous version. Thanks @FelixVeitl for pointing it out :point_down:

I just learned that this dialogue may swallow the actual error message - there is a fix already in place. It will be contained in the next release (thanks @wngr).
In the meantime, you should be able to find the error in the logs. They are in C:\Program Files\Actyx\Node in the default installation.

Would you mind hopping over to our Discord channel so we can analyze together with less lag?

I dont have the Core directory, only the Nodes. I just tried installing it again but no change in this matter. Of course I can join the server.

We diagnosed it together directly on zoom.

Results:

  • Manifest was missing in one app
  • One (machine state) event was not fired, so the machine didn’t show up on the dashboard
  • The binary (C:\Program Files\Actyx\Node\actyx.exe) could not be started, since the installer already created the service & started it, so the ports were already used. This led to the error message above. Starting the binary manually is not required if Actyx is installed on Windows using the installer.