Quickstart tutorial does not seem to work?

Hi there,
for the purpose of helping a new member I tried the quickstart tutorial again, but it seems it is not working properly.
When I ran it, nothing appeared:

I checked the event stream through the node manager, they seem to be emitted correctly:

as far as I can tell, the code seems fine, too.

import { allEvents, FishId, Metadata, Pond, Tag } from '@actyx/pond'
import manifest from './manifest.json'

const HelloWorldFish = {
  fishId: FishId.of('com.example.quickstart', 'quickstart', 0),
  initialState: 'Hello, World!',
  onEvent: (_oldState: any, event: any, _metadata: Metadata) => event,
  where: allEvents,
}

const main = async () => {
  const pond = await Pond.default(manifest)
  pond.observe(HelloWorldFish, state => console.log(state))

  var counter = 1
  setInterval(() => {
    pond.emit(Tag('Some tag'), `Hello ${counter}!`)
    counter += 1
  }, 3500)
}

main()

I believe I did this months ago without any problem…
Btw, I am currently at ver. 2.10
I am not able to troubleshoot this. Did I miss anything here?

Your help is appreciated!

Hi Dipta,

thanks for bringing this up. There were some outdated dependencies. I have just fixed them and I think it should work now. LMK if it doesn’t!

Cheers,
Oliver

Hi Oli,

thank you, they are working correctly now.

Dipta

1 Like